运行eclipse时出错an error has occurred eclipse

问题描述:

运行eclipse时出错an error has occurred eclipse
我的电脑之前装过JRE1.6 昨天还能运行 然后百度了一下说JDK包括JRE 就把JRE1.6删了去SUN官网下了最新的JDK1.7 结果eclipse就不能运行了
1个回答 分类:综合 2014-09-17

问题解答:

我来补答
一般装JDK会安装2个JRE,在JDK目录下的JRE是内用的,版本和JDK一致,一般不升级不打补丁.用于针对该版JDK的调试开发.这一套是用来开发的
单独的JRE是外用的,用来运行通用Java程序的.会和浏览器、资源管理器整合,会自动和oracle同步更新.这一套就相当于flash player,只用来播放的.
如果你把外用的JRE删了,很多整合都打破了.通常是2个jre都保留,如果要删也去删内用的那个JRE.
只有较新的Eclipse4.x才支持Java 7 , 现在4.x已经进入测试发布阶段基本稳定了,可以用.我用了一阵子了,没异常.3.x不支持Java 7语法,且不时会有不兼容的情况. 3.x建议还是用Java 6
?
?
展开全文阅读
剩余:2000
黄色视频网